SOLVED: The AMP plugin requires iconv extension in PHP




After updating the  AMP plugin for WordPress to version 1.0.1, some users are experiencing an issue as below.

"The AMP plugin requires iconv extension in PHP. Please contact your host to install this extension."

To fix the issue, we need to install the required iconv extension which can be done as follows:


  1. 1. SSH into your host as root, eg: ssh [email protected]
  2. 2. Run the following command to install iconv extension: yum install ea-php56-php-iconv